Wiesshund's profile

Sat, Apr 27, 2019 10:00 AM

Error when sending MMS text messages Message not sent: Service not activated on network.

Error when sending MMS text messages Message not sent: Service not activated on network.

Phones messaging app is google Messages

I can receive SMS and MMS fine, but i can not send anything, i get the error Message not sent: Service not activated on network.

I worked with Google on the issue and they say it is a carrier issue.

I even sent the phone in to kyocera, they sent it back and also said the phone was fine and the software was fine
that it was carrier related

 

And I already did a reset on the phone, factory reset, reset networks etc and then let it re-update, no change.

 

So Boost guys,  how do we rectify this?

 

My phone is a Hydro ICON

Android KitKat 4.4.2

 

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

5 Messages

2 y ago

wifi is off, rpl updated
messages is version 2.9.052

 

It tries to send, LTE icon starts spinning, can even see phone get its location
but does not send, tries for a bit then says message not sent: service not activated on network

Boost Care

 • 

3.9K Messages

2 y ago

Hi there! Please turn off your Wifi, then make sure that your mobile data is On, update your PRL by going to Settings > System Updates and try to send it again. Do not turn on your Wifi until you manage to send out an MMS successfully. Let us know how it goes. 

5 Messages

2 y ago

Message not sent: Service not activated on network.
was the result

Boost Care

 • 

3.9K Messages

2 y ago

Hmm. That doesn't sound right. Let's take a closer look! Please send us a private message so we may work directly with you. 

 

You can send a private message by clicking on an agent's name, then selecting the message option from the profile page. 

Boost Care

 • 

2.2K Messages

2 y ago

We replied to your private message. 

8 Messages

10 m ago

same issue after updating PRL, Profile, software

# # 72786 # worked

Dial that and let it reset. It'll give you some scary message but then everything came right back